(CF)Eclipse/Flex Builder workspace crash – solution…?

by kai on 14/07/2006



Eclipse is an awesome platform, I totally converted all my development to it some while ago and I even use it for writing documents in LaTeX in Eclipse. Just a while ago, I failed to get Marty from 01 converting to Eclipse as well, particularly to CFEclipse.

One of the reasons was that his Eclipse installation just broke down at least once totally – apparently his workspace crashed and Eclipse didn’t start up. It was just sitting there consuming tons of memory and doing nothing after the splash screen.

Yesterday I was having the same issue. We had a short power issue and my machine just shut down more or less instantly while I was developing some CF stuff in Eclipse. After power was back and the box rebooted, Eclipse didn’t start – same issue as Marty’s.

I did some research and found that there is a file called .snap in the depth of your workspace structure which could get corrupted and cause this behaviour. That particular discussion thread in a forum said that if one deleted that file, Eclipse would start up, but all project setting would be gone.

Well, I thought that that might be the smaller issue compared to setting up the environment again, so I just gave it a try. Deleted the file, Eclipse started and all my settings were still there.

So: if your workspace crashes at some point, try to remove the file: .metadata\.plugins\org.eclipse.core.resources\.snap from your workspace folder (maybe just move it first) and see what happens. Worked for me…!

{ 1 comment… read it below or add one }

Jens Frandsen February 20, 2008 at 12:00 am

Thanks

Eclipse crashed on my computer (due to a program waiting for reply for too long and not wanting to shut down) and Eclipse was unable to start because the workspace was reported as being in use. After moving the .snap file, Eclipse started again.

/Jens

Reply

Cancel reply

Leave a Comment

Previous post:

Next post: