Mystic beta 3 and Multiserver installations

by kai on 14/05/2006



Today I was trying to set up Mystic beta 3 for my multiserver configuration on my work machine. I run CF 7, Flex 1.5 and some more instances containing Java apps on JRun 4 (Windows box, default installation on C drive).

When I was stepping through the installation wizard of Mystic all was fine up to the point when I had to decide for standalone or multiserver. I know that standalone works fine, I’ve done it already on another machine. To continue my multiserver setup, the installer asked for my JRun root/base directory and suggested c:\jrun4 – which was indeed the correct directory. But: it didn’t work, after selecting it, the installer complained that it couldn’t find any clue that this one really was the JRun directory. I’ve tried various subdirectories, but didn’t make a differenceat all.

Anybody else out there having this issue? 🙂

{ 5 comments… read them below or add one }

John Barrett May 14, 2006 at 12:00 am

Hi,
When I installed this on my mac the installer found /Applications/JRun4 fine, but for some reason it installed an extra copy of CFIDE in my harddrive(Macintosh HD),which I thought was strange(as I don’t understand how JRun or CF can find this location).

I think that all went well during the install.
John

Reply

João Fernandes May 14, 2006 at 12:00 am

I have also multiserver installation and the update worked just fine. I also have multiple instances working and all got updated. Did you check the updater log to see where it failed?

Reply

John Wilker May 14, 2006 at 12:00 am

I had the same problems. I don’t know if there is a better solution, but what worked for me was to blow away jrun and CF, reinstall.

I don’t know what was different, because I installed to the same places I had before (C:/jrun4) but mystic liked that install fine and installed on the first try.

Reply

Dirk May 15, 2006 at 12:00 am

Have you installed JRun 4 first and then deployed CF and Flex 1.5 to it or is it a real “CF multiserver-config”, where you installed CF with the multiserver option? I successfully deployed FDS and Mystic on the latter but I’m not sure if the first one will work.

Dirk.

Reply

Douglas May 15, 2006 at 12:00 am

I did not have that same error but I did have a similar one. I am using ACME/Flex 2 Beta 3 and I did the default Mystic install to C:/JRun4, which worked. Later, I tried to create a Coldfusion/Flash Remoting project using the default directory but kept getting the “doesn’t exist” error. Turns out that the directory Mystic/Flex wants is the Web Root. Try to change the install path to your web root i.e. “C:/inetpub/wwwroot/”. If that doesn’t work it might be the version of Flex you are using. Hope it helps, 😉

Reply

Cancel reply

Leave a Comment

Previous post:

Next post: