Railo and ColdFusion on Java 7: don’t forget the crypto extensions

by kai on 02/04/2013



So – more on the whole Java 7 thing again.

The other day I got an “Illegal key size or default parameters” error on one of my dev VMs. I was using the VM for quite a while and from what I could see the codebase had not changed significantly. Weird.

All of a sudden I realised that I recently upgraded the CF instance on the dev VM to Java 7. Doh! As the code is using strong encryption, I used to have the Java Cryptography Extensions with Unlimited Strength installed and I just forgot to do that for the Java 7 VM.

Those extensions are tied to specific JVM instances and not to your Railo or CF installation, keep that in mind.

{ 1 comment… read it below or add one }

Jo C April 2, 2013 at 11:21 am

Yup – I upgraded our production servers this weekend to Java 7 and we had exactly that problem – I was scratching my head for quite a while until a colleague who had written the particular piece of code using the extensions came to my rescue! Phew I didn’t have to roll it all back!

Reply

Cancel reply

Leave a Comment

Previous post:

Next post: